Aller au contenu


Photo

[Switch] Caffeine pour le FW 4.1.0 et les Switch patchées


  • Veuillez vous connecter pour répondre
41 réponses à ce sujet

Posté 26 juin 2019 - 07:22

#1
tralala

tralala

    \0/ Postman \0/

  • Newser Expert
  • 8 260 messages
  • Sexe:Male
Caffeine, l'exploit warmboot, basé sur Deja Vu pour la Nintendo Switch qui permet de lancer les payload RCM, vient d'être mis à jour pour supportter le firmware 4.1.0.
 
L'exploit, pour rappel, fonctionne même sur les Switch patchées, c'est donc une première, les Switch patchées sont désormais capables de lancer un CFW complet à condition d'être restées en 4.1.0 au maximum.
 
 
 
 
PegaScape a également été mis à jour pour inclure cette nouvelle version de Caffeine, donnant aux utilisateurs un moyen facile d'en profiter sur leurs consoles (gardez à l'esprit, cependant, que même si l'exploit lui-même est publiquement disponible, PegaScape est encore limité aux seuls utilisateurs d'AtlasNX).
 
 
 
 
 
 
 
 
 
 
 
 
Cependant, si vous voulez essayer vous-même, soyez très prudent lorsque vous utilisez homebrew capable d'apporter des modifications permanentes au NAND de votre système. 
 
Attention, sur une console non patchée, il est facile de corriger des bugs, mais sur une Switch patchée vous pouvez bricker plus facilement. N'activez en aucun cas l'AutoRCM sur une console patchée, vous risqueriez de l'endommager.
 
D'autre part, il est fortement recommandé de faire une sauvegarde NAND dès que possible et de dumper vos clés en utilisant Lockpick_RCM. Vous pouvez également configurer emuMMC pour exécuter des jeux et homebrew en utilisant n'importe quel firmware supérieur tout en laissant sysNAND sur 4.1.0 pour démarrer Caffeine.
 

 
Up to now, almost all homebrew for the Switch have been developed with the concept in mind that everyone has access to RCM. As such, most homebrew and especially RCM payloads have zero protection for users on IPATCHED units.
 
Understand that this means it is incredibly easy to do something which, while considered normal on consoles with an exploitable RCM, can render IPATCHED Switches permanently inoperable. For your safety, you should avoid using the following homebrews on IPATCHED systems:
 
memloader
ChoiDujour
ChoiDujourNX (safe on emuMMC, do not use on sysnand)
Anything involving AutoRCM (briccmii, SX OS payload, etc)
Many homebrews have been updated to block enabling AutoRCM on IPATCHED units including Hekate and ChoiDujourNX. Still exercise very high caution.
Anything which writes to sysNAND without proper security or verification in place
Upon using PegaScape to reboot into a payload on an IPATCHED Switch, you should immediately create a NAND backup with Hekate and dump all of your keys (especially BIS keys) with Lockpick_RCM. Understand that by not dumping these, there is no recovery method for your Switch should anything cause it to fail to boot.
 
You should strongly consider using an emuMMC for all CFW usage to avoid any damage to your Switch.
 
That said, celebrate! We can now run CFW on IPATCHED Switches!

 

 

 
 
 
Tout est là : 
 
 
 
Fichier précompilé de caffeine 1.1 :
 
 
 
 
 
 
 
 
 

  • Retour en haut

Posté 26 juin 2019 - 07:38

#2
Linkynimes

Linkynimes

    Sunriseur elite

  • Members
  • PipPipPipPip
  • 1 448 messages
  • Sexe:Male
Merci pour la news
  • Retour en haut

Posté 26 juin 2019 - 07:39

#3
L - Lawliet

L - Lawliet

    Sunriseur

  • Members
  • PipPip
  • 108 messages
  • Sexe:Male
  • Lieu:Japon
  • Passions:Informatique, Programmation, Montage vidéo, Lire, hack de manière générale, Animées...
Merci pour la news, cet exploit avance c’est génial :)

S'il vous plaît, je le dis très souvent, j'en ai conscience, mais ne mettez jamais a jour votre sysNAND...

  • Retour en haut

Posté 26 juin 2019 - 07:53

#4
cesarhiino

cesarhiino

    Sunriseur

  • Members
  • PipPip
  • 90 messages
  • Sexe:Male
  • Passions:Automobile, jeux videos...
Ca avance c'est cool ca !

Modifié par cesarhiino, 26 juin 2019 - 07:54.

  • Retour en haut

Posté 26 juin 2019 - 08:00

#5
Fujilecr

Fujilecr

    Sunriseur

  • Members
  • PipPip
  • 53 messages
Baaaaah pourquoi ma switch patcher est en 8.1 !!!
  • Retour en haut

Posté 26 juin 2019 - 08:02

#6
Fujilecr

Fujilecr

    Sunriseur

  • Members
  • PipPip
  • 53 messages
Dites moi une switch neuve est livrée avec quel firmware ?
  • Retour en haut

Posté 26 juin 2019 - 08:05

#7
Linkynimes

Linkynimes

    Sunriseur elite

  • Members
  • PipPipPipPip
  • 1 448 messages
  • Sexe:Male

Dites moi une switch neuve est livrée avec quel firmware ?


7.0 / 8.0
Tu trouvera une 4.1 que d'occasion
  • Retour en haut

Posté 26 juin 2019 - 08:08

#8
shadow256

shadow256

    Sunriseur PRIVILEGE

  • Members
  • PipPipPipPipPip
  • 5 351 messages
  • Sexe:Male
Pour info, ceci n'est pas utilisable que pour les utilisateurs de Pegascape, avec PegaSwitch ça peut être mis en place, j'ai tenté une intégration dans mon Ultimate Switch Hack Script (fonctionnalité utilisant Nereba) mais par contre j'ai pas eu le temps de tester donc si des utilisateurs veulent me faire un retour sur le sujet du script se sera utile.

J'ajoute également que cette exploit sera mis à jour prochainement pour les firmwares allant jusqu'au 7.0.1 il me semble donc si vous voulez profiter du hack sur les consoles patchées je suggère de ne pas aller au-delà de celui-ci, d'ailleurs je conseil même de n'aller que jusqu'au 6.0.1 car je pense que la prochaine évolution sera pour ce firmware maximum. Ceux en firmware 7.X.X et supérieurs par contre vous risquez d'attendre longtemps et en 8.X.X et supérieur là c'est pas pour demain je pense, l'exploit Dejavu étant totalement patché sur ces firmwares (le truc c'est que je ne me souviens plus à partir de quel firmware exact la faille Dejavu a été réellement patchée, si quelqu'un peut donner l'info exacte).

Modifié par shadow256, 26 juin 2019 - 08:19.

Mes créations:
Switch Payload Injector Script
Ultimate PS3 Hack Script
Ultimate Wii U Hack Script

Matériel:

Spoiler

  • Retour en haut

Posté 26 juin 2019 - 08:17

#9
bigcitylife

bigcitylife

    Sunriseur

  • Members
  • PipPip
  • 110 messages
Très bonne nouvelle !
  • Retour en haut

Posté 26 juin 2019 - 09:00

#10
Fujilecr

Fujilecr

    Sunriseur

  • Members
  • PipPip
  • 53 messages
Sa viendra pour les autres FW suffit d'attendre j'ai deux switch une patch et une non patch sa va je me plaint pas pour le moment mais si les 2 était jailbreak ce serait mieux
  • Retour en haut

Posté 26 juin 2019 - 09:11

#11
eliboa

eliboa

    Sunriseur elite

  • Members
  • PipPipPipPip
  • 1 684 messages
  • Sexe:Male

le truc c'est que je ne me souviens plus à partir de quel firmware exact la faille Dejavu a été réellement patchée, si quelqu'un peut donner l'info exacte

Déjà vu est complètement patché depuis la 8.0. Pourtant aucun fuse n'est grillé par cette version et ce depuis la 7.0 ce qui est bizarre de la part de nintendo :) seule la 8.1 grille un nouveau fuse.


Modifié par eliboa, 26 juin 2019 - 09:14.

Tuto Switch : Bloquer les maj | Supprimer les maj téléchargées | Lancer Linux | Lancer des payloads

switch-h4x0r |`FW max conseillé sur Switch => 4.1

 

  • Retour en haut

Posté 26 juin 2019 - 10:13

#12
Charpy

Charpy

    Sunriseur

  • Members
  • PipPip
  • 109 messages
Formidable!
  • Retour en haut

Posté 26 juin 2019 - 10:26

#13
bouboul13

bouboul13

    Sunriseur

  • Members
  • PipPip
  • 101 messages
Ha ! ça sent très bon tout ça
Exploit à suivre de près pour les firmwares supérieurs
Merci ;-)
  • Retour en haut

Posté 26 juin 2019 - 11:32

#14
Retroman

Retroman

    Sunriseur

  • Members
  • PipPip
  • 205 messages
bonjour, j'ai une Switch dev kit6 en 3.4.0, puis je utiliser ce exploit caffeine?

Mon jeu survival préféré : C'est un jeu ou on est assaillis par des trolls et il faut survivre. De temps en temps on a des boss (très rare, et qui sont faciles à battre), mais la plupart du temps on tombe sur des zombies qui lancent des attaques "downgrade", et l'espèce qui a le plus proliféré c'est "Vous êtes des pigeons". Les pires ennemis dans ce jeu sont les pubs instang-arnaque. :wanna-fight:

  • Retour en haut

Posté 26 juin 2019 - 11:56

#15
davidcampbelle

davidcampbelle

    Sunriseur avancé

  • Members
  • PipPipPip
  • 424 messages

le truc c'est que je ne me souviens plus à partir de quel firmware exact la faille Dejavu a été réellement patchée, si quelqu'un peut donner l'info exacte

Déjà vu est complètement patché depuis la 8.0. Pourtant aucun fuse n'est grillé par cette version et ce depuis la 7.0 ce qui est bizarre de la part de nintendo :) seule la 8.1 grille un nouveau fuse.



Le nombre de fuses doit être limité Nintendo peut être pas se permettre d’en griller à chaque mise à jour.


Si déjà-vu à était complètement patcher on devrait le voir arriver au public bientôt

Modifié par davidcampbelle, 26 juin 2019 - 12:01.

  • Retour en haut

Posté 26 juin 2019 - 12:07

#16
eliboa

eliboa

    Sunriseur elite

  • Members
  • PipPipPipPip
  • 1 684 messages
  • Sexe:Male

Le nombre de fuses doit être limité Nintendo peut être pas se permettre d’en griller à chaque mise à jour.

Oui le SoC ne contient que 32 eFuses. Le truc bizarre c'est qu'en général Nintendo grille un fuse à chaque changement majeur de version. C'est la première fois que N passe deux version majeures sans griller de fuses (7.x à 8.0) alors même que le fw 8.0 patche complétement déjà vu.

 

efuses.png

Le truc bien c'est que même les Switchs "non patchées" en 8.0.1 pourront profitez du hack software (après downgrade). A condition de pas griller ses fuses au delà de 9 évidemment.


Tuto Switch : Bloquer les maj | Supprimer les maj téléchargées | Lancer Linux | Lancer des payloads

switch-h4x0r |`FW max conseillé sur Switch => 4.1

 

  • Retour en haut

Posté 26 juin 2019 - 12:36

#17
shadow256

shadow256

    Sunriseur PRIVILEGE

  • Members
  • PipPipPipPipPip
  • 5 351 messages
  • Sexe:Male

Le truc bien c'est que même les Switchs "non patchées" en 8.0.1 pourront profitez du hack software (après downgrade). A condition de pas griller ses fuses au delà de 9 évidemment.

Oui enfin pour les Switch non patchées et l'arrivée de l'emunand pour Atmosphere vaut mieux se prendre un dongle+jig ou s'installer une puce (si on sait le faire sois-même), ça coûte une dizaine d'euros (on peut même ne rien débourser si on a déjà un smartphone compatible et un bout d'aluminium mais bon je trouve la solution dongle+jig plus safe et plus pratique, surtout si on utilise le hack sur plusieurs consoles) et on peut à la fois profiter du hack en Emunand et d'une utilisation normal en sysnand, finalement on s'en fiche un peu de l'exploit software pour les Switch non patchées mis à part pour les développeurs/testeurs ou certains utilisateurs ne souhaitant pas upgrade la console. Si encore on pouvait booter sans être obligé d'avoir une connexion internet ou quoi que se soit faudrait voir genre mise en cache de l'exploit comme sur PS4 là ça deviendrait un peu plus intéressant mais en l'état pour les Switch non patchées l'intérêt est assez moyen au final car on a toujours besoin d'un élément extérieur pour que ça fonctionne, avant c'était un truc pour injecter le payload via le RCM et maintenant c'est une connexion internet. Et merci pour la confirmation du firmware sur lequel Dejavu a été complètement patché, c'était bien se qui me semblait mais j'avais des doutes parce qu'il me semble qu'une partie de la chaîne de l'exploit a été patchée plus tôt.

Mes créations:
Switch Payload Injector Script
Ultimate PS3 Hack Script
Ultimate Wii U Hack Script

Matériel:

Spoiler

  • Retour en haut

Posté 26 juin 2019 - 12:48

#18
Ays

Ays

    Sunriseur

  • Members
  • PipPip
  • 224 messages
  • Sexe:Male
  • Lieu:Algérie/Paris/annaba
  • Passions:Vidéos games
Après pour les jeux qui demandent fw récent comment faire !??

Modifié par Ays, 26 juin 2019 - 12:48.

  • Retour en haut

Posté 26 juin 2019 - 12:57

#19
davidcampbelle

davidcampbelle

    Sunriseur avancé

  • Members
  • PipPipPip
  • 424 messages

Après pour les jeux qui demandent fw récent comment faire !??


Utiliser un Emunand à jour tout simplement
  • Retour en haut

Posté 26 juin 2019 - 12:57

#20
eliboa

eliboa

    Sunriseur elite

  • Members
  • PipPipPipPip
  • 1 684 messages
  • Sexe:Male

Oui enfin pour les Switch non patchées et l'arrivée de l'emunand pour Atmosphere vaut mieux se prendre un dongle+jig ou s'installer une puce (si on sait le faire sois-même), ça coûte une dizaine d'euros (on peut même ne rien débourser si on a déjà un smartphone compatible et un bout d'aluminium mais bon je trouve la solution dongle+jig plus safe et plus pratique, surtout si on utilise le hack sur plusieurs consoles) et on peut à la fois profiter du hack en Emunand et d'une utilisation normal en sysnand, finalement on s'en fiche un peu de l'exploit software pour les Switch non patchées mis à part pour les développeurs/testeurs ou certains utilisateurs ne souhaitant pas upgrade la console. Si encore on pouvait booter sans être obligé d'avoir une connexion internet ou quoi que se soit faudrait voir genre mise en cache de l'exploit comme sur PS4 là ça deviendrait un peu plus intéressant mais en l'état pour les Switch non patchées l'intérêt est assez moyen au final car on a toujours besoin d'un élément extérieur pour que ça fonctionne, avant c'était un truc pour injecter le payload via le RCM et maintenant c'est une connexion internet. Et merci pour la confirmation du firmware sur lequel Dejavu a été complètement patché, c'était bien se qui me semblait mais j'avais des doutes parce qu'il me semble qu'une partie de la chaîne de l'exploit a été patchée plus tôt.

Oui je suis d'accord que l'intérêt est tout relatif pour les Switch non patchées, d'autant qu'il sera compliqué de pouvoir jouer online car la sysNAND ne pourra pas être à jour du dernier firmware. Il faudra s'y risquer en emuNAND (même si je pense que ça peut le faire avec une emunand propre c'est quand même bien plus risqué). Avec un point d'entrée plus accessible qu'un exploit webkit ça serait clairement intéressant par contre.

Et en effet des parties de l'exploit chain "déjà vu" ont déjà été corrigés dans les firmwares précédents.


Tuto Switch : Bloquer les maj | Supprimer les maj téléchargées | Lancer Linux | Lancer des payloads

switch-h4x0r |`FW max conseillé sur Switch => 4.1

 

  • Retour en haut




0 utilisateur(s) li(sen)t ce sujet

0 invité(s) et 0 utilisateur(s) anonyme(s)