Aller au contenu


megaoctet

Inscrit(e) (le) 17 mars 2010
Déconnecté Dernière activité août 13 2019 21:52
****-

#1064479 [Switch] Kosmos 13.0.2 disponible

Posté par megaoctet - 07 juillet 2019 - 21:55

Merci à tous ces newsers et tous ces devs. Je suis heureux de lire les news de tralala, les news des nouveaux, Même s il y a des fautes (tu en faisais aussi hein!) Le site vie . Il me semble que beaucoup de gens sont motivé pour le faire tourner et pour aider et ça c est cool.


#1061654 [Switch] Atmosphere v0.9.0 avec support Emummc

Posté par megaoctet - 16 juin 2019 - 18:32

Il faut l ignorer le Troll! Le manque de considération le fera retourner dans sa grottes ! Très belle avancée de la part de nos Dev talentueux !!


#1056552 [Switch] SX OS Beta v2.7.1 disponible

Posté par megaoctet - 03 mai 2019 - 23:31

Tous ces posts sur une simple news me donneraient presque envie de redevenir modo. ;)




#1043236 [Switch] The-4n propose une nouvelle version du HBmenu "légal"

Posté par megaoctet - 10 février 2019 - 12:00

Bravo pour son "travail"!
Y a un "copié collé" de trop dans la news :)


#1033544 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 23:02

Hello ,

Je viens de faire un dernier test pour la route

J'ai dumper le fichierSYSTEM via HacDisk , j'en ai donc profiter pour récupérer les fichiers a l'intérieur.

J'ai lancé l'emunand, j'ai mis a jour en 6.2 via choixdujour

J'ai redumper le Fichier SYSTEM via HacDisk et j'ai récupérer les fichiers aussi.

 

Les deux fichiers SYSTEM ne matchent pas un offset en erreur "offset 10C082D0" juste la ligne tous le reste du fichier est ok

 

Je me suis dis chouette ayant récupérer les fichiers je vais bien trouvé le fautif

Le SHA256 de tous le dossier et exactement pareil pour les deux ca commence mal :(

 

Je suis pas sûr qu'il faille que je compare fichiers par fichiers via l'éditeur du coup !

 

Voilà je sais pas quand j'aurais le temps de me replonger la dedant ;) 




#1033471 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 19:31

Je pense pas que ça puisse venir d'hekate, la partition ne pourrait pas être déchiffrée avec les BIS keys si elle était altérée par hekate, je pense. 

Pas bête sinon l'idée de shadow de bricker sa nand et voir si le CFW en emunand est capable de lancer Horizon tout seul. 

Il faudrait aussi qu'on sache si seul le fichier PRF2SAFE.RCV est touché.

j'espère qu'on aura le fin mot de cette histoire, vu le temps que vous avez passés megaoctet et Tesla ^^

Bon j'ai comparé les fichier a l'interieur de SYSTEM ils sont tous pareil :(  SHA256 semblable)

Peut etre que ca aurait été deux dump identiques.

J'ai fait un dump sysnand complet "rawnand.bin"

un Dump via hekate de "SYSTEM"

un DUmp via HacDIsk de "SYSTEM"

J'ai copié les fichiers a l'interieur de SYSTEM

Je suis prêt a les supprimer et à tester ;)

Je reviens!

 

Edit: Je suis bien dans l'emunand sans soucis

        Le lecteur "SYSTEM" une fois monté est toujours vide donc rien n'a été écrit

        Bon je confirme que la console ne boot plus en Sysnand :)

        Aprés restauration de SYSTEM tout est revenu dans l'ordre 

 

Donc comme dirait l'autre ne rien trouver c'est déjà trouver quelque chose ! 




#1033430 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 16:52

Du coup comme le dit @eliboa on peut clairement affirmer que des fichiers de la sysnand peuvent être modifiés par l'emunand (en plus ça semble peut-être aléatoire), ça craint je trouve, auto-RCM ou non cela n'y change rien. Quelque soit les fichiers modifié cela ne devrait pas se produire, surtout que c'est la partition "SYSTEM" qui est modifiée.

Du coup petite théorie de ma part, il est possible que SX OS lance la partition "SYSTEM" pour rediriger ensuite vers l'emunand, expliquant qu'il puisse y avoir des modifications de la partition "SYSTEM". Pour vérifier cela il faudrait intentionnellement bricker la partition "SYSTEM" en supprimant tous les fichiers se trouvant dessus puis en lançant l'emunand (l'emunand devra bien-sûre être créé avant cela et les fichiers de la partition "SYSTEM" doivent être sauvegardées pour être restaurés ensuite après le test (attention, bien afficher le fichiers cachées pour être certains de tout sauvegarder/restaurer) ou sauvegarder/restaurer la partition "SYSTEM" avec HacDiskMount et Memloader, c'est plus simple au final).

Bon je test les fichiers de SYSTEM aprés les avoir extrait (via memloader et hacDiskMout)

Mais tout à l'air ok entre les deux "version" Avant et aprés lancement de l'Emunand!

Est ce que le soucis pourrait venir du dump du fichier SYSTEM depuis hekate? Ca m'étonnerait ! 

 

Je vois que dans les nouveautés de Sxos on peut dumper la sysnand (en plusieurs parties, USER, SYSTEM...)

Je tente de faire deux dumps via leur interface 




#1033337 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 12:40

Tu peux monter ta NAND comme un lecteur physique depuis ton PC (sans dump donc). Pour ça il faut utiliser TegraRcmSmash.exe pour lancer memloader et ums_emmc.ini (tout est dispo sur le site de raj => https://switchtools.sshnuke.net/)

Ensuite tu pourras ouvrir ce lecteur avec HacDiskMount (File > Open physical drive) et tes BIS keys.

 

Ca devrait être plus rapide pour tes tests que systématiquement faire un dump :)

 

edit : l'utilisation de memloader est décrite à l'étape C de ce tuto http://www.logic-sun...-all-firmwares/

 

 

Memloader est aussi géré par mon script, lancement direct du bon "ini" sans avoir à copier quoi que se soit sur la SD.

 

On vous aime tous les deux ;)

Et ce que vous faite pour la scéne Switch est trés enrichissant !! 

 

Je vais faire ça pour voir ce que je peux en tirer!

Peut on "recompiler" un rawnand.bin depuis ces fichiers séparément  (USER,SYSTEM,SAFE...)?




#1033314 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 11:40

Est-ce que c'est le fichier PRF2SAFE.RCV à nouveau ? Ou bien est-ce que ce sont un ou plusieurs NCA qui sont touchés, c'est ce qu'il faudrait savoir maintenant. 

Arf! je n'ai pas refait de dump complet du coup. (étant parti sur l'idée de faire fichiers par fichiers)  Donc je ne peux le savoir!

A moins qu'il ai un moyen d'accéder à ce fichier SYSTEM mais j'ai testé avec hacdisk, il ne veut que le rawnand.bin complet :(

 

Désolés pour le double post j'ai fait une fausse manip !! ;)




#1033312 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 11:36

Ben je comprend plus rien a ce problème. Pourquoi je n'ai aucun changement entre 2 backup ? Alors que toi oui. (et je suis sur que c'est pas un fail de backup que j'aurais copier 3 fois, car j'ai fait les 3 backup avec 3 sd differente car la copie sur mon pc était très lente car j'avais pas mon adaptateur usb3)

Je referais un test dans l'aprem.

Hello

Pas de soucis , merci pour tes tests

Surement quelques chose qui se passe sur ma switch ! mais chez moi le fichiers SYSTEM ramasse à chaque passage sur l'emunand

Je dois bien dire que je capté pas trop non plus.

Si c'était des erreurs de transfert ou autres, les autres fichiers pourrait être impacté

Aprés tous mes test d'hier soir (j'ai tous remis a zero et recrée une emunand clean) , je vais refaire un dump complet de tous mes fichiers (SYSTEM, USER...), Ca me refera une nouvelle base propre pour d'autres tests!

Et les recomparer avec les tous premiers que j'ai fait (n'ayant jamais été sur la sysnand, ils devraient être tous pareil sauf le SYSTEM! , qui lui est déjà différents .)




#1033223 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 23 décembre 2018 - 00:32

Bon je reviens avec toujours la même constatation !

 

Aprés avoir configuré l'emunand 6.0.1 fraichement crée, j'ai changé le theme, renommer la console et créer un profil

J'ai éteint la console "normalement" et j'ai refait un Dump via hekate en plusieurs fichiers (BCPKG2, PRODINFO, SAFE...)

J'ai testé les fichiers des deux Dumps 1 par 1

 

Et j'en ai un qui match pas c'est le fichier SYSTEM  Taille: 2684354560 octets SHA256: BD6059AF21FF06933E50D6269A18D7E33C5374396A5673E96A1E53C9D9F7FF06

Tous le reste est ok

 

La je vois pas ; est ce que brancher la console (électriquement) pendant le Dump peut générer des différences?

 

Je vais redumper juste ce fichier (relativement rapide du coup)

Edit: Sans rien lancer d'autres le fichier SYSTEM est identique à celui du dump d'avant.

 

Aprés je retourne faire "mumuse" avec l'emunand et je retest

Edit: bon le fichier SYSTEM est de nouveau différent, juste en lançant l'emunand :(

 

Bon je viens de redumper le fichier SYSTEM sans avoir rien lancé, et ben devinez quoi?

Il est identique à celui d'avant ;)

 

Il faudrait par curiosité que d'autres fassent des tests parce que je vais devenir fou si je suis le seul à avoir un soucis avec ça ...

Vu qu'apparemment il faut dumper juste le fichier SYSTEM ca va plus vite (5mn top chrono, 2mn si on vire la vérification dans hekate)

 

Bon dernier test, j'ai lancé l'emunand , j'ai installé youtube nsp

J'ai refait un dump mais j'ai laissé la même sd (vu que le fichier SYSTEM fait 2 giga, j'ai la place)

En me disant que peut etre en changeant de SD il y a quelque chose qui modifie la sysnand!

Mais non même avec la même sd ,j'ai toujours une différence dans le fichier SYSTEM dés que je lance l'émunand!

 

A Tester les amis :)




#1033202 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 22 décembre 2018 - 21:39

C'est toi Grosbin des doigts ?
[Petit clin d'œil Web série]

:)

 

Bon sysnand 6.0.1 remise a zéro (je ne l'ai même pas lancé pour les premiers paramétrages)

Dump 1 fait (fait pris les parties séparément (BCPKG2, PRODINFO, SAFE...)

Carte Sd formatée exfat 64 giga 

Emunand en cours d'installation donc en 6.0.1 (vierge) d'ailleurs il a pas voulu me faire le mode hidden partition (pas assez d'espaces Oo)

Donc faut une 128 giga mini

Aprés je lance l'emunand , je redump la sysnand pour voir




#1033159 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 22 décembre 2018 - 18:43

Oui tu as probablement raison. On se ferait quand même moins chi** à se poser ce genre de question si on avait accès à leur code source mais bon ^^

Et faut avouer que leur première emuNAND en partition de la NAND était quand même bizarre d'où l'affolement généralisé au début.

Pas mal de gens attendent de savoir si leur emuNAND est safe avant de jouer online sur leur sysNAND, tous ces tests auront au moins le mérite de nous éclairer la dessus, c'est pas du temps perdu :)

Sauf si le gars qui fait les tests a des gros doigts ;)




#1033140 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 22 décembre 2018 - 17:53

 

Megaoctet , emunand sur la SD (pas dans une partition). C'est une fonctionnalité de la 2.4 ou 2.5 l'emunand sur partition

OK merci de l'info je vais voir pour repartir au plus propre ;)

 

la création de l'emunand  date un peu (la sysnand de base doit etre 5.0.1 je crois ) et a subit tout est n'importe quoi ;)

Ma sd aussi a pas mal de fichiers de connerie dessus

 

Je vais refaire tous ça propre en partant de la sysnand 6.0.1 "clean"

Peut être un bug sur les premiére version d'émunand 

 

Mais donc , le probléme vient de chez moi c'est une "ICC" ;)

 

@inconnuX c'est juste que lorsque tu lances le processus auto de sx os pour créer l'emunand , il commence par dumper ta sysnand et leurs choix est de le faire en plusieurs parties on a pas la main la dessus!




#1033137 Est ce que la Sysnand communique avec l'emunand?

Posté par megaoctet - 22 décembre 2018 - 17:38

Donc j'ai effectué 3 backups: (entre tous les backup, je n'ai JAMAIS booter sur la sysnand)

  - avant création emunand 

  - après création emunand  (donc emunand avec la même version que le sysnand)

  - après boot en emunand avec lancement de jeux xci avec update intégré, installation de nsp (youtube patched)

 

Et les 3 backups sont tous identiques (md5)

 

Donc je sais pas comment vous avez réussi a faire pour avoir des changements mais le seul changement que j'ai observer, c'est si je boot en OFW et que je refais un backup, le backup est différent.

 

Pour info j'ai fait mes backup a partir de hekate pour avoir directement le backup des partitions séparées (plus simple pour identifier la zone d'un changement possible)

merci pour ces tests 

JE vais creuser de mon côté

La seule différence avec toi apparemment c'est que j'ai fait la mise a jour avec choixdujour de mon emunand! en 6.2 (ton emunand tu l'a faite en fichier sur la sd ou sur une partition de la sd) D'ailleurs c'est une option qu'il y avait dés le début? Car quand j'ai fait mon emunand dés l'arrivé de cette possibilité, j'ai pas souvenir d'avoir eu ce choix!

Mais je n'ai pas booté en sysnand entre deux non plus!