Aller au contenu


Photo

[Switch] Atmosphere 1.1.1 disponible


  • Veuillez vous connecter pour répondre
63 réponses à ce sujet

Posté 24 septembre 2021 - 20:29

#1
tralala

tralala

    \0/ Postman \0/

  • Newser Expert
  • 10 580 messages
  • Sexe:Male
SciresM vient de mettre en ligne une toute nouvelle version d'Atmosphere qui est proposée en v1.1.1.
 
 
 
 
Atmosphere 1.1.1 est la cinquante-sixième version officielle d'Atmosphère, merci de noter que cette version 1.1.1 est fournie avec hbl 2.4.1 et hbmenu 3.4.1.
 
 
Les modifications suivantes ont été apportées depuis la dernière version :
 
- Un bug a été corrigé qui provoquait une fuite de mémoire lors du lancement d'un jeu avec des mods activés, provoquant éventuellement un crash après suffisamment de lancements de jeu sans redémarrage.
- Améliorations générales de la stabilité du système pour améliorer l'expérience de l'utilisateur.
 
Et les modifications suivantes ont été apportées dans la version 1.1.0 :
 
- Le support de la version 13.0.0 a été implémenté.
- Mesosphère a été mis à jour pour refléter le dernier comportement officiel du noyau.
- ncm a été mis à jour pour refléter les derniers comportements officiels.
- erpt a été mis à jour pour refléter les derniers comportements officiels.
- Deux nouveaux services ("sprofile") ont été ajoutés à erpt, et ont été entièrement réimplémentés.
- Remarque : ces services permettent de pousser les paramètres vers les consoles via Internet sans mise à jour du système.
- Comme il semble qu'il n'y ait pas encore de paramètres poussés, cette implémentation ne peut fondamentalement pas être entièrement testée pour le moment, mais nous espérons qu'il n'y aura pas de problèmes lorsque les paramètres commenceront à être distribués.
- Le module système LogManager a été réimplémenté. Ce module système fournit des services que certains jeux utilisent pour la journalisation.
- La réimplémentation d'Atmosphere prend en charge la journalisation sur la carte SD (si lm!enable_sd_card_logging est vrai) et sur ams.TMA.
- Pour contrôler le répertoire où les journaux sont enregistrés, modifiez le paramètre lm!sd_card_log_output_directory.
- La réimplémentation d'Atmosphere est désactivée par défaut (afin d'économiser de la mémoire), mais peut être activée en mettant lm!enable_log_manager à true. Cela permettra de lire les logs des jeux qui utilisent les services (ou potentiellement les logs de homebrew dans le futur), ce qui peut être utile aux développeurs.
- Veuillez noter que lorsque la TMA sera entièrement implémentée à l'avenir, l'activation de la TMA entraînera l'activation forcée de LogManager.
- Améliorations générales de la stabilité du système pour améliorer l'expérience de l'utilisateur.
 
 
Téléchargement : Atmosphere 1.1.1
 
Merci Sendel
 

  • Retour en haut

Posté 24 septembre 2021 - 20:42

#2
Linkynimes

Linkynimes

    Sunriseur PRIVILEGE

  • Members
  • PipPipPipPipPip
  • 2 960 messages
  • Sexe:Male
^^

Mon pack pour les intéressé déjà à jour : https://github.com/T...atch.13.0.0.zip
La version pour les switchs patcher sous SXCore ou HWFLY :
https://github.com/T...h.FW.13.0.0.zip

gros gg a SciresM c'est un monstre :)
  • Retour en haut

Posté 24 septembre 2021 - 20:47

#3
shadow256

shadow256

    Sunriseur PRIVILEGE

  • Members
  • PipPipPipPipPip
  • 8 684 messages
  • Sexe:Male

Et les sig_patches sont à jour ici.

Mon Ultimate-Switch-Hack-Script est également à jour pour supporter le firmware 13.0.0 et les nouveautés récentes du hack Switch.


Modifié par shadow256, 24 septembre 2021 - 20:48.

Mes créations:
Ultimate-Switch-Hack-Script, mon plus gros projet
Ultimate Wii U Hack Script, mon premier projet, plutôt complet
Ultimate PS3 Hack Script, un projet peut utile aujourd'hui

Si vous aimez mon travail, vous pouvez me faire une donation via paypal en cliquant ici, pensez que même un euro se sera déjà beaucoup et très apprécié.

Matériel:

Spoiler

Posté 24 septembre 2021 - 21:00

#4
Lbn

Lbn

    Sunriseur

  • Members
  • PipPip
  • 126 messages
Mise à jour des sigpatchs de THZoria également.

Modifié par Lbn, 24 septembre 2021 - 21:00.

  • Retour en haut

Posté 24 septembre 2021 - 21:12

#5
Redgis

Redgis

    Sunriseur

  • Members
  • PipPip
  • 82 messages
Top merci pour tout
  • Retour en haut

Posté 24 septembre 2021 - 22:10

#6
jachen

jachen

    Sunriseur

  • Members
  • PipPip
  • 41 messages
Bonjour @Linkynimes
Merci pour ce pack.

Actuellement, je suis sous Emunand CFW 11.0.1 avec Atmosphère 0.18.1

1 - Pas de soucis pour mettre à jour directement vers Atmosphère 1.1.1.
Il suffit de copier l'ensemble de ton pack et remplacer... ?

2 - Y a t-il des modifications à faire ? Je me souviens que @shadow256 parlait de modifications/suppressions de fichiers sur des versions Atmosphère antérieures ?

3 - L'ordre pour réaliser cette opération est mise à jour Atmosphère et puis mise à jour du CFW 13.0.0 via Daybreak ?

4 - Je peux continuer à injecter le payload "fusée" via tegraRCMgui ?


Merci d'avance pour la confirmation de ces 4 points.
  • Retour en haut

Posté 25 septembre 2021 - 01:00

#7
mojo1119

mojo1119

    Sunriseur

  • Members
  • PipPip
  • 166 messages
Je me pose la question, comment passé du emunande sx os 11. 0 , a une emummc 13.0, surtout j'aimerais savoir la marche a suivre, sans avoir de problème du port cartouche,compatiblité des jeux ect...Jai téléchargé le pack ici...

Nintendo switch firmware sysnand13.0 ,CFW :Atmosphère 1.1.1   Méthode utilisé:Émunand emummc  cfw13.0 .

Anciennement (avant le 1 octobre 2021)  sysnand  9.0.1 emunand sx os 11.0

Méthode de boot:sx pro + JIG , payload:hekate 5.6.3 . 

-Homebrew préférer: mission contôle et goldleaf et rétroarch

-Manette préférer utilisé avec Mission contrôle : dualshock4 (ps4)

-Dans quel mode j'utilise le plus la nintendo switch? : portable. 

-mon jeux vidéo préférer : Runescape oldschool et zelda , série horreur ,genre resident evil

switch no.série

-xaw1000*******

  • Retour en haut

Posté 25 septembre 2021 - 01:04

#8
shadow256

shadow256

    Sunriseur PRIVILEGE

  • Members
  • PipPipPipPipPip
  • 8 684 messages
  • Sexe:Male
@jachen : En dessous de Atmosphere 0.19.0 il faut absolument nettoyer le dossier "contents", j'ai pas en tête tous les noms des dossiers à supprimer dans ce dossier mais pour le savoir il suffit de récupérer Atmosphere 0.18.X et de regarder dans le dossier "atmosphere\contents", se sont ces dossiers qu'il faut supprimer. Ensuite le fichier "atmosphere\fusee-secondary.bin" est à supprimer ainsi que le fichier "atmosphere\fusee-mtc.bin", le dossier "atmosphere\kip_patches\default_nogc" et enfin, s'il existe, supprimer le fichier "atmosphere\config\bct.ini" et "atmosphere\config_templates\bct.ini". Et oui, le payload "fusee.bin" peut être injecté via TegraRCMGui, faut juste penser à récupérer toujours la dernière version du fichier ou du moins celle qui correspond à la version d'Atmosphere utilisée.

@mojo1119 : Sujet déjà mainte et mainte fois abordé sur le forum, notamment dans ce sujet pour l'emunand et ce sujet pour le patch nogc.

Modifié par shadow256, 25 septembre 2021 - 01:08.

Mes créations:
Ultimate-Switch-Hack-Script, mon plus gros projet
Ultimate Wii U Hack Script, mon premier projet, plutôt complet
Ultimate PS3 Hack Script, un projet peut utile aujourd'hui

Si vous aimez mon travail, vous pouvez me faire une donation via paypal en cliquant ici, pensez que même un euro se sera déjà beaucoup et très apprécié.

Matériel:

Spoiler
  • Retour en haut

Posté 25 septembre 2021 - 06:19

#9
mimyo

mimyo

    Sunriseur

  • Members
  • PipPip
  • 28 messages

^^

Mon pack pour les intéressé déjà à jour : https://github.com/T...atch.13.0.0.zip
La version pour les switchs patcher sous SXCore ou HWFLY :
https://github.com/T...h.FW.13.0.0.zip

gros gg a SciresM c'est un monstre :)

Salut, j'utilise ton pack (merci pour le boulot) cependant pourquoi tu ne mets pas a jour hekate et nyx??
  • Retour en haut

Posté 25 septembre 2021 - 06:40

#10
Linkynimes

Linkynimes

    Sunriseur PRIVILEGE

  • Members
  • PipPipPipPipPip
  • 2 960 messages
  • Sexe:Male

^^Mon pack pour les intéressé déjà à jour : https://github.com/T...atch.13.0.0.zipLa version pour les switchs patcher sous SXCore ou HWFLY :https://github.com/T...h.FW.13.0.0.zipgros gg a SciresM c'est un monstre :)

Salut, j'utilise ton pack (merci pour le boulot) cependant pourquoi tu ne mets pas a jour hekate et nyx??

Hekate est à jour ? C'est Hekate 5.6.2 et Nyx 1.0.7
  • Retour en haut

Posté 25 septembre 2021 - 08:02

#11
lanfeust333

lanfeust333

    Nouveau / peu actif

  • Members
  • Pip
  • 4 messages
Bonjour,

J'ai une switch en firmware v12, est ce que vous me conseillez de la passer en v13 avant de la hacker ou vaut il mieux rester en V12.
Plus globalement, est ce que les homebrews sont compatibles avec des firmwares inférieurs ?
Merci.
  • Retour en haut

Posté 25 septembre 2021 - 08:30

#12
LOUSTIK

LOUSTIK

    Sunriseur avancé

  • Members
  • PipPipPip
  • 390 messages
  • Sexe:Male
  • Passions:Foot,jeux video,globe trotters,f1

Bonjour,J'ai une switch en firmware v12, est ce que vous me conseillez de la passer en v13 avant de la hacker ou vaut il mieux rester en V12.Plus globalement, est ce que les homebrews sont compatibles avec des firmwares inférieurs ?Merci.

slt Deja il faut savoir si ta switch est patchée ou pas https://damota.me/ssnc/checker/

Si c'est pas clair essaye d'injecter un payload
http://www.logic-sun...hee-ou-non.html

Modifié par LOUSTIK, 25 septembre 2021 - 08:38.

  • Retour en haut

Posté 25 septembre 2021 - 08:47

#13
Lestat___

Lestat___

    Sunriseur avancé

  • Members
  • PipPipPip
  • 922 messages
  • Sexe:Not Telling

Merci pour la news.

Sous mariko et sx core, le pack https://github.com/T...h.FW.13.0.0.zip

m'a créé des corruptions de sd sur tous les jeux installés sur la base d'un xci.

Impossible d'utiliser ns-usbloader pour installer même des nsp.

 

J'ai repris atmo et hekate sur github, les sigpatches chez totaljustice et surtout, je pense que mon soucis venait de là, j'ai édité le fichier hekate_ipl.ini:

[config]
autoboot=0
autoboot_list=0
autohosoff=0
autonogc=1
backlight=100
bootwait=0
updater2p=1

[CFW - sysMMC]
fss0=atmosphere/package3
icon=bootloader/res/icon_payload.bmp
kip1patch=nosigchk
atmosphere=1
emummc_force_disable=1

[CFW - emuMMC]
fss0=atmosphere/package3
icon=bootloader/res/icon_payload.bmp
kip1patch=nosigchk
atmosphere=1
emummcforce=1

[Stock - sysMMC]
fss0=atmosphere/package3
icon=bootloader/res/icon_switch.bmp
emummc_force_disable=1
stock=1

à la place de celui de Lynkinimes:

{--- Stock ---}
[Stock (SYSNAND)]
emummc_force_disable=1
fss0=atmosphere/package3
stock=1
icon=bootloader/res/stock_boot.bmp
{}

{------ Atmosphere ------}
[Ams CFW emuMMC]
fss0=atmosphere/package3
kip1=atmosphere/kips/*
kip1=atmosphere/kips/*
emummcforce=1
icon=bootloader/res/emu_boot.bmp
{}

[Warmboot Error Fix]
fss0=atmosphere/package3
stock=1
emummc_force_disable=1
icon=bootloader/res/icon_switch.bmp

 

Tout refonctionne normalement.


  • Retour en haut

Posté 25 septembre 2021 - 09:05

#14
lanfeust333

lanfeust333

    Nouveau / peu actif

  • Members
  • Pip
  • 4 messages

Bonjour,J'ai une switch en firmware v12, est ce que vous me conseillez de la passer en v13 avant de la hacker ou vaut il mieux rester en V12.Plus globalement, est ce que les homebrews sont compatibles avec des firmwares inférieurs ?Merci.

slt Deja il faut savoir si ta switch est patchée ou pas https://damota.me/ssnc/checker/Si c'est pas clair essaye d'injecter un payloadhttp://www.logic-sun...hee-ou-non.html

Pas patchée car c'est une ancienne switch, achetée d'occase aprés avoir vérifié le SN ;) j'en ai une autre récente que je garde tel quel pour que les enfants puissent jouer en ligne.

Modifié par lanfeust333, 25 septembre 2021 - 09:07.

  • Retour en haut

Posté 25 septembre 2021 - 11:19

#15
jachen

jachen

    Sunriseur

  • Members
  • PipPip
  • 41 messages

@jachen : En dessous de Atmosphere 0.19.0 il faut absolument nettoyer le dossier "contents", j'ai pas en tête tous les noms des dossiers à supprimer dans ce dossier mais pour le savoir il suffit de récupérer Atmosphere 0.18.X et de regarder dans le dossier "atmosphere\contents", se sont ces dossiers qu'il faut supprimer. Ensuite le fichier "atmosphere\fusee-secondary.bin" est à supprimer ainsi que le fichier "atmosphere\fusee-mtc.bin", le dossier "atmosphere\kip_patches\default_nogc" et enfin, s'il existe, supprimer le fichier "atmosphere\config\bct.ini" et "atmosphere\config_templates\bct.ini". Et oui, le payload "fusee.bin" peut être injecté via TegraRCMGui, faut juste penser à récupérer toujours la dernière version du fichier ou du moins celle qui correspond à la version d'Atmosphere utilisée.


Merci @shadow256 pour tes conseils.
Mise à jour Emunand effectuée en CFW V. 13.0.0 et avec Atmosphère V. 1.1.1.

En fait, j'ai supprimer l'ensemble des données de ma carte SD sauf le dossier Nintendo (qui contient mes sauvegardes) et le dossier emuMMC (qui contient mon Emunand).
J'ai copié l'ensemble des fichiers et dossiers du pack de Linkynimes à la racine de la SD.
J'ai injecté "fuséee" (même fichier que celui contenu dans le pack : bootloader/payload) avec TegraRCMgui et parfait.

Cerise sur le gâteau : j'ai pu connecter mon casque Bluetooth...

Merci encore à @shadow256 pour son aide précieuse (quand on n'est pas un expert) et à @Linkynimes pour son pack prêt à l'emploi !

Modifié par jachen, 25 septembre 2021 - 11:21.

  • Retour en haut

Posté 25 septembre 2021 - 12:23

#16
davidcampbelle

davidcampbelle

    Sunriseur avancé

  • Members
  • PipPipPip
  • 482 messages

@jachen : En dessous de Atmosphere 0.19.0 il faut absolument nettoyer le dossier "contents", j'ai pas en tête tous les noms des dossiers à supprimer dans ce dossier mais pour le savoir il suffit de récupérer Atmosphere 0.18.X et de regarder dans le dossier "atmosphere\contents", se sont ces dossiers qu'il faut supprimer. Ensuite le fichier "atmosphere\fusee-secondary.bin" est à supprimer ainsi que le fichier "atmosphere\fusee-mtc.bin", le dossier "atmosphere\kip_patches\default_nogc" et enfin, s'il existe, supprimer le fichier "atmosphere\config\bct.ini" et "atmosphere\config_templates\bct.ini". Et oui, le payload "fusee.bin" peut être injecté via TegraRCMGui, faut juste penser à récupérer toujours la dernière version du fichier ou du moins celle qui correspond à la version d'Atmosphere utilisée.


Merci @shadow256 pour tes conseils.
Mise à jour Emunand effectuée en CFW V. 13.0.0 et avec Atmosphère V. 1.1.1.

En fait, j'ai supprimer l'ensemble des données de ma carte SD sauf le dossier Nintendo (qui contient mes sauvegardes) et le dossier emuMMC (qui contient mon Emunand).
J'ai copié l'ensemble des fichiers et dossiers du pack de Linkynimes à la racine de la SD.
J'ai injecté "fuséee" (même fichier que celui contenu dans le pack : bootloader/payload) avec TegraRCMgui et parfait.

Cerise sur le gâteau : j'ai pu connecter mon casque Bluetooth...

Merci encore à @shadow256 pour son aide précieuse (quand on n'est pas un expert) et à @Linkynimes pour son pack prêt à l'emploi !


Salut,

Moi c'est ce que je fais a chaque fois, je garde le dossier Nintendo, le dossier qui contient l'emunand et le dossier Switch qui contient les hombrews.
J'efface le dossier atmosphère et je le réinstalle avec la dernière version comme ça aucun problème ça repart sur une base neuf et ça prend 5 minutes même en reconfigurant les quelques paramètres que j'effectue avec atmosphère.
  • Retour en haut

Posté 25 septembre 2021 - 12:31

#17
extenue

extenue

    Sunriseur

  • Members
  • PipPip
  • 122 messages
bonjour , existe t'il des jeux necessitant un FW 12 au minimum ?

EDIT (et Marcel) : http://nswdb.com/

Modifié par extenue, 25 septembre 2021 - 12:34.

  • Retour en haut

Posté 25 septembre 2021 - 13:00

#18
Vinzoide

Vinzoide

    Sunriseur

  • Members
  • PipPip
  • 48 messages
AIO-switch-updater
Et
MissionControl

A jour aussi.
  • Retour en haut

Posté 25 septembre 2021 - 13:58

#19
LOUSTIK

LOUSTIK

    Sunriseur avancé

  • Members
  • PipPipPip
  • 390 messages
  • Sexe:Male
  • Passions:Foot,jeux video,globe trotters,f1

Bonjour,J'ai une switch en firmware v12, est ce que vous me conseillez de la passer en v13 avant de la hacker ou vaut il mieux rester en V12.Plus globalement, est ce que les homebrews sont compatibles avec des firmwares inférieurs ?Merci.

slt Deja il faut savoir si ta switch est patchée ou pas https://damota.me/ssnc/checker/Si c'est pas clair essaye d'injecter un payloadhttp://www.logic-sun...hee-ou-non.html

Pas patchée car c'est une ancienne switch, achetée d'occase aprés avoir vérifié le SN ;) j'en ai une autre récente que je garde tel quel pour que les enfants puissent jouer en ligne.

Alors fonce tu peux la mettre en 13 et mettre le dernier atmo.
La compatibilité va suivre pour les homebrews

Modifié par LOUSTIK, 25 septembre 2021 - 14:04.

  • Retour en haut

Posté 25 septembre 2021 - 16:25

#20
xave

xave

    Sunriseur avancé

  • Members
  • PipPipPip
  • 626 messages
  • Sexe:Male
merci mise a jour effectuer parfait tout roule :)
  • Retour en haut




0 utilisateur(s) li(sen)t ce sujet

0 invité(s) et 0 utilisateur(s) anonyme(s)