Aller au contenu


Photo

[PS4Linux] Installation des pilotes AMDGPU-PRO


  • Veuillez vous connecter pour répondre
12 réponses à ce sujet

Posté 10 mai 2018 - 08:59

#1
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages

Bonjour.

 

Apres avoir discuté longuement avec Marcan, le premier a avoir réussi a exécuter Vulkan depuis une PS4, il s'est avéré qu'il n'a rien fait d'autre que d'installer les pilotes AMDGPU-PRO proposés par AMD. C'est d'ailleurs pour ça qu'il n'a jamais publié "ses" pilotes: car il n'y avait rien a publier!

Marcan m'a révélé que le pilote AMDGPU-PRO ne se limite pas aux modèles des cartes graphiques supportées, mais plutôt aux "familles" auxquelles ils appartiennent.

Fort heureusement, la famille qui nous intéresse et qui inclut le GPU Liverpool de la PS4 est supporté (il s'agit du groupe "Sea Island", dans lequel on trouve notamment le GPU de la Xbox One...).

AMD propose ses pilotes pour les distributions Red Hat/CentOS et Ubuntu/Open Suse. Vu qu'il est facilement possible d'installer Ubuntu sur ps4, ou est le problème me diriez-vous? 

Le problème, c'est que nous avons fait un choix: celui d'Arch Linux*. Or, installer ces pilotes sur Arch Linux est légèrement compliqué...

Le pilote est bien évidement disponible sur AUR, mais n'a plus été mis a jour depuis 6 mois (dernières mise a jour en date: 18.10, contre 17.40 pour le pilote dispo sur AUR). Du coup, impossible de l'installer sans se heurter a des erreur de dépendances insolubles.

La seule solution est de tenter une conversion des paquets.

En ce qui me concerne j'ai déjà tenté de convertir les paquets de façon brut via debtap. Les résultats sont... mitigés: d'un coté , certains paquets s'installent sans trop se faire prier, et de l'autres j'obtiens la mortelle erreur des dépendances inresolvable... 

Je vous invite a tenter l'expérience de votre coté : https://support.amd....ease-Notes.aspx

Si ça vous intéresse, je peux aussi vous fournir mes paquets convertis, mais il s'agit d'une conversion assez bâclée...

 

*Si quelqu'un souhaite tester les pilotes sur Ubuntu ou Fedora, un retour serait le bienvenu. La version minimale d'Ubuntu supportée est la 16.04.4. Par contre j'ai tenté Lubuntu 16.04.4, 17.10 et 18.04. Rien a faire, le noyau Linux refuse de booter dessus...


Modifié par shim80, 10 mai 2018 - 10:49.

  • Retour en haut

Posté 10 mai 2018 - 14:23

#2
tikilou

tikilou

    Sunriseur avancé

  • Technicien
  • 306 messages

Bonjour.
 
Apres avoir discuté longuement avec Marcan, le premier a avoir réussi a exécuter Vulkan depuis une PS4, il s'est avéré qu'il n'a rien fait d'autre que d'installer les pilotes AMDGPU-PRO proposés par AMD. C'est d'ailleurs pour ça qu'il n'a jamais publié "ses" pilotes: car il n'y avait rien a publier!
Marcan m'a révélé que le pilote AMDGPU-PRO ne se limite pas aux modèles des cartes graphiques supportées, mais plutôt aux "familles" auxquelles ils appartiennent.
Fort heureusement, la famille qui nous intéresse et qui inclut le GPU Liverpool de la PS4 est supporté (il s'agit du groupe "Sea Island", dans lequel on trouve notamment le GPU de la Xbox One...).


Merci pour l'info, je n'ai plus de matos AMD depuis des années sous Linux, étant donné qu'il y avait beaucoup de problème de performances à une époque...

 

AMD propose ses pilotes pour les distributions Red Hat/CentOS et Ubuntu/Open Suse. Vu qu'il est facilement possible d'installer Ubuntu sur ps4, ou est le problème me diriez-vous? 
Le problème, c'est que nous avons fait un choix: celui d'Arch Linux*. Or, installer ces pilotes sur Arch Linux est légèrement compliqué...
Le pilote est bien évidement disponible sur AUR, mais n'a plus été mis a jour depuis 6 mois (dernières mise a jour en date: 18.10, contre 17.40 pour le pilote dispo sur AUR). Du coup, impossible de l'installer sans se heurter a des erreur de dépendances insolubles.


Je vais me pencher dessus et voir, merci pour la piste.
 

La seule solution est de tenter une conversion des paquets.


Grosse erreur, ça ne fonctionne que pour des logiciels qui ne sont pas critiques po 
*Si quelqu'un souhaite tester les pilotes sur Ubuntu ou Fedora, un retour serait le bienvenu. La version minimale d'Ubuntu supportée est la 16.04.4. Par contre j'ai tenté Lubuntu 16.04.4, 17.10 et 18.04. Rien a faire, le noyau Linux refuse de booter dessus...


Logique, ça ne fonctionnera pas, il faudrait reprendre les patchs de la team ps3ita point par point, récupérer les sources des paquets Ubuntu, patcher ces dernières, compiler, puis empaqueter les binaires comme le font les mainteneurs d'origine.
Mais personnellement je ne le ferais pas pour Ubuntu, j'ai fait le choix de Manjaro car elle est encore plus accessible, propose un dépôt communautaire énorme et accessible à tous, et SURTOUT ne sera pas obsolète dans 6 mois ! Celui qui récupère Manjaro PS4 V2, s'il veut dans deux ans il fait sa maj, il a toutes les dernières versions de logiciels/environnements/outils, alors que sur Ubuntu, en version LTS il pourra faire une mise à jour mais n'aura que de vieilles versions, et sur version non LTS, les mises à jour ne seront plus supportées, il faudra upgrader la distribution, et prendre le risque de tout casser...

Pour l'instant je me penche sur un port autonome de Kodi sur PS4, mais dès que je peux me pencher sur ces pilotes proprios AMD, je le fais !


Ps : je cherche des infos pour compiler le payload Linux loader de valentinbreizh => https://github.com/v...Loader/issues/5

Modifié par tikilou, 10 mai 2018 - 14:39.

  • Retour en haut

Posté 10 mai 2018 - 15:14

#3
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages

Ok. En ce qui me concerne, je viens de tenter d'installer les drivers AMDGPU-PRO sur une des distributions supportées par AMD, a savoir: CentOS.

Les pilotes se sont installés sans aucun souci, mais après le redémarrage j'ai eu droit a une magnifique mosaïque de pixels... 


  • Retour en haut

Posté 10 mai 2018 - 15:18

#4
tikilou

tikilou

    Sunriseur avancé

  • Technicien
  • 306 messages
Par curiosité j'ai pris le temps de regarder vite faite, je pense qu'installer ces pilotes est possible MAIS, nous avons besoin que quelqu'un nous fasse un paquet kernel-headers contenant les sources du dernier noyau proposé par la team PSxita.

Car comme n'importe quel driver externe au noyau, ce dernier est chargé sous forme de module binaire, et une portion de code doit être compilé pour être adapté au noyau Linux en cours d'utilisation, pouvoir ensuite être chargé.

Pour te donner un exemple, regarde le contenu du paquet proposé pour la version 4.14 du noyau Linux par la Team Manjaro => http://kibo.remi.lu/...6_64.pkg.tar.xz

Mais l'on ne peut pas utiliser ce paquet, il faut remplacer les sources de leur noyau (qui a ses propres patchs) par celui de la team ps3ita, en cours d'utilisation ! ;)


Hors je viens de regarder, avec leur dernière distribution ils ont sorti un nouveau Bzimage (le noyau Linux) contenant des mises à jour (pilote bluetooth, wifi, etc...) mais les sources sur le github n'ont pas été mises à jour... (Et ça c'est pas cool, c'est une obligation de la licence de repartager le code source après modification quand on publie des binaires compilés...)

Modifié par tikilou, 10 mai 2018 - 15:23.

  • Retour en haut

Posté 10 mai 2018 - 15:52

#5
tikilou

tikilou

    Sunriseur avancé

  • Technicien
  • 306 messages

Ok. En ce qui me concerne, je viens de tenter d'installer les drivers AMDGPU-PRO sur une des distributions supportées par AMD, a savoir: CentOS.
Les pilotes se sont installés sans aucun souci, mais après le redémarrage j'ai eu droit a une magnifique mosaïque de pixels...


Oui, il faudra malgré tout profiter des patchs de la team ps3ita... Qui sont sur Manjaro/ArchLinux


Par contre, je pense qu'il faudra passer quelques paramètres du noyau au boot, et on en revient à ce que j'essaie de faire, recompiler le payload linux loader de valentinbreizh, regarde ce fichier => https://github.com/v...5/source/main.c

Sur les lignes 157/158/159 :

char *cmd_line = "panic=0 clocksource=tsc radeon.dpm=0 console=tty0 console=ttyS0,115200n8 "
"console=uart8250,mmio32,0xd0340000 video=HDMI-A-1:1920x1080-24@60 "
"consoleblank=0 net.ifnames=0 drm.debug=0";

C'est exactement comme avec Grub sur PC, je pense qu'il va falloir enlever radeon.dpm=0 pour profiter du pilote AMD-GPU-Pro, aussi. Car cet argument est spécifique au pilote libre.

 

Seulement, je bloque pour obtenir le même résultat que ValentinBreizh, sans même encore avoir touché à son code source => https://github.com/v...Loader/issues/5


Modifié par tikilou, 10 mai 2018 - 15:54.

  • Retour en haut

Posté 10 mai 2018 - 20:50

#6
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages

Il faut d'abord verifier jusqu'à quelle version les pilotes AMDGPU-PRO supportent les GPU GCN ("Sea Island")...

D'après la page d'AMD, certains vieux GPU* ne sont pas supportes par les nouveaux pilotes...

Grace a Marcan, on sait déjà que la version 16.50 supporte Liverpool. Reste a savoir jusqu'à quand...

 

*D'après ce vieux tweet de Marcan, le GPU de la Xbox One (Kryptos) était supporté jusqu'à la version 16.40... 


Modifié par shim80, 10 mai 2018 - 20:56.

  • Retour en haut

Posté 11 mai 2018 - 00:10

#7
tikilou

tikilou

    Sunriseur avancé

  • Technicien
  • 306 messages

Il faut d'abord verifier jusqu'à quelle version les pilotes AMDGPU-PRO supportent les GPU GCN ("Sea Island")...

D'après la page d'AMD, certains vieux GPU* ne sont pas supportes par les nouveaux pilotes...

Grace a Marcan, on sait déjà que la version 16.50 supporte Liverpool. Reste a savoir jusqu'à quand...

 

*D'après ce vieux tweet de Marcan, le GPU de la Xbox One (Kryptos) était supporté jusqu'à la version 16.40... 

 

 

Okay, donc ça ne va pas être de la tarte, comme c'est un pilote proprio ça signifie qu'il faudrait downgrader Xorg et le noyau...
Je te conseille de remonter toutes ces infos à la team PS3ita, si certains ont les moyens de booter un vieux noyau Linux & xorg & utiliser ce driver, et faire du reverse engeenering pour que ça profite au pilote libre, c'est bien eux...


  • Retour en haut

Posté 11 mai 2018 - 09:09

#8
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages

... donc ça ne va pas être de la tarte, comme c'est un pilote proprio ça signifie qu'il faudrait downgrader Xorg et le noyau...

Marcan semble pouvoir lancer son pilote depuis le kernel 4.10 RC2. D'après ce que j'ai pu voir, le bzimage utilisé dans ton Manjaro utilise le kernel 4.9...

Concernant le downgrade de Xorg, il me semble que c'est déjà le cas avec les pilotes proposés par psxita, au vu des soucis que j'ai eu pour les installer la première fois...

 

Je te conseille de remonter toutes ces infos à la team PS3ita, si certains ont les moyens de booter un vieux noyau Linux & xorg & utiliser ce driver, et faire du reverse engeenering pour que ça profite au pilote libre, c'est bien eux...

Fait : https://www.ps3ita.i...-ps4-t6121.html


  • Retour en haut

Posté 11 mai 2018 - 09:16

#9
tikilou

tikilou

    Sunriseur avancé

  • Technicien
  • 306 messages

Marcan semble pouvoir lancer son pilote depuis le kernel 4.10 RC2. D'après ce que j'ai pu voir, le bzimage utilisé dans ton Manjaro utilise le kernel 4.9...

Concernant le downgrade de Xorg, il me semble que c'est déjà le cas avec les pilotes proposés par psxita, au vu des soucis que j'ai eu pour les installer la première fois...

 

Fait : https://www.ps3ita.i...-ps4-t6121.html


Le kernel installé dans Manjaro ne compte pas, vu qu'on charge celui dans la partition FAT du média USB au lancement du Payload. Ici donc, le dernier BZimage en date proposé par la team Ps3ita est la version 4.14.14

 

Concernant Xorg, il est possible qu'il faille une version plus ancienne encore, et celle qu'ils proposent n'est pas si ancienne, c'est juste celle qui était proposée dans les mises à jour au moment ou ils ont patchés les sources.

Merci pour la remontée ! ;)


  • Retour en haut

Posté 12 mai 2018 - 18:35

#10
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages

En fouillant un peu sur psxhax, je suis tombé sur des pilotes AMDGPU-PRO (version 17.10) pour Arch Linux spécialement conçus pour les GPU GCN : https://github.com/l...x-amdgpu-vk-ocl

Le pilote s'installe sans soucis (ni aucun conflit de dépendances...) et le redémarrage se fait sans encombres. Par contre, quand j'essaye de tester le pilote avec des samples Vulkan, j'obtiens l'erreur 

drm version is 2.50.0 but this driver is only compatible with 3.x.x

  • Retour en haut

Posté 13 mai 2018 - 08:27

#11
tikilou

tikilou

    Sunriseur avancé

  • Technicien
  • 306 messages

 

En fouillant un peu sur psxhax, je suis tombé sur des pilotes AMDGPU-PRO (version 17.10) pour Arch Linux spécialement conçus pour les GPU GCN : https://github.com/l...x-amdgpu-vk-ocl

Le pilote s'installe sans soucis (ni aucun conflit de dépendances...) et le redémarrage se fait sans encombres. Par contre, quand j'essaye de tester le pilote avec des samples Vulkan, j'obtiens l'erreur 

drm version is 2.50.0 but this driver is only compatible with 3.x.x

 

 

Ça signifie sans doute que Vulkan tente d'utiliser le pilote libre radeon et non le pilote AMDGPU-Pro, merci pour la trouvaille, je vais devoir faire des tests aussi...

 

 

Pour info, Marcan n'a pas simplement fait qu'installer les pilotes AMDGPU-Pro, la preuve => https://github.com/f...209007ef7e1eedc

Reste à savoir si la team PS3ita a repris ce patch pour sa version customisée de libdrm, vu ton message d'erreur, j'ai un doute...


Modifié par tikilou, 13 mai 2018 - 08:43.

  • Retour en haut

Posté 13 mai 2018 - 08:59

#12
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages
Voici les mots exacts de Marcan, lorsqu'on en a discuté par mails:

I have no idea why people keep asking me about Vulkan drivers. I just use AMD's official Linux Vulkan drivers. There is no magic, nothing to release.
The drivers are generic enough, they don't care about the specific chip, only the generation (Sea Islands). All the required information and chip-specific details are provided by the kernel driver.


  • Retour en haut

Posté 16 mai 2018 - 11:07

#13
shim80

shim80

    Sunriseur avancé

  • Members
  • PipPipPip
  • 520 messages

J'ai demande plus de precision a Marcan quand a la facon dont il a installe les pilotes AMDGPU-PRO sur son Linux.

Malheureusement, il m'a indique avoir fait tout son taf sur un Linux auquel je n'ai pas la moindre experience: Gentoo.

 

Sorry, I only tested Gentoo Linux with package versions which were
current as of over a year ago. We have a Gentoo Portage overlay with old
versions here:

https://github.com/f...low/ps4-overlay

You'll probably have to forward port things to the curent version
yourself. I only tested the AMDGPU-PRO Vulkan drivers, still using Mesa
for Xorg, so they would not affect Xorg in general, only Vulkan apps.

You also need updated GPU microcode as provided by the
sys-firmware/ps4-ucode ebuild (see the postinst message for more
information).

If you want to use another distro you'll have to figure out how to build
patched packages for it yourself.

Good luck.


  • Retour en haut




0 utilisateur(s) li(sen)t ce sujet

0 invité(s) et 0 utilisateur(s) anonyme(s)